iAudiophile.net Forums


Go Back   iAudiophile.net Forums > Hard Disk Players > Cowon X7

Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-12-2011, 09:04   #1
Mark Coyle
Member
 
Join Date: Jun 2010
Posts: 124
Default How to get the best from X7 as a music player

Hi all

Introduction & Initial X7 experience

I was a happy J3 owner and recently decided to update to the X7 for more space. I knew the pros and cons and was pleasantly surprised that the screen resolution and touch response seemed fine to me.

I did however have issues with the device as a music player which was the primary purpose I had purchased it for. So I set about getting the most from it.

The three key issues I had were:
- the album art stretching or not showing as widely reported
- the genre tag showing multiple or no genres for the music.
- the device disconnecting as a drive while in Windows when copying music onto it.

I have therefore written the following guide as to how I resolved these issues and made the device the player I hoped it could be. I hope it is helpful and everyone should feel free to use it as you see fit and re-post this guide if useful.


A guide to
How to get the best from the Cowon X7 as a music player
by Mark Coyle


Displaying Album Art properly

First I wanted to sort the album art issue. All my album art is both embedded into the track and sorted as a folder cover.jpg with each album. I use 300dpi jpegs at 500x500 and was determined that the X7 could show it properly as the device is essentially a hard drive based J3 which had no problem.

I realised that the standard operating system wasn't able to sort this so I needed to use a User Customised Interface (UCI) which a number of enterprising people had created for the S9 and J3. These should work in theory so as an experienced J3 owner I set about checking through all the J3 and S9 UCIs on the X7 available from this iAudiophile site.

After a thorough review of about 20 UCIs I am delighted to report that the Sense UCI was absolutely perfect for me and easy to install. It is available here:
http://iaudiophile.net/forums/forumdisplay.php?f=111

As it is a music UCI, all other features of the X7 including System Settings are left alone. I have found it to be fully compatible with the device.

The UCIs are available at no cost from talented users of Cowon devices to further improve and enhance our experience of them. It's a real benefit to using Cowon products.

It shows the album art in a perfect square at full screen width without distorting and picks up all art once the music tags are sorted. The album art looks absolutely fantastic and in the correct dimensions.

Additionally this UCI has extensive controls available by touching the top of the album art, including hidden tools for album art, track gaps etc. These are accessed from the menu I mentioned then the bottom left square symbol. You can also edit User EQ settings right from the music player visually.

To install a UCI just download and unzip it, then copy the files into the System/Flash folder of your X7 then reboot it.

The UCI provides the following:
- Album Art at right dimensions
- Track view or if you swipe it right 'next track' (swipe left to go back)
- Rewind / Pause / Forward controls on screen
- Tap top of album art for control menu.

At control menu

Controls similar to J3 / standard X7:
- Row 1 top from left - Library access, close menu, home
- Row 2 - Playlist controls
- Row 3 - Play once, shuffle on/off, boundary (track, folder, all)
- Row 4 - EQ select (with sub-menu overlay)
- Row 5 - Track speed, balance
- Row 6 - Track loop, EQ Setting Edit (with sub-menu screens that are better than that provided with the Firmware)
- Row 7 - Square symbol accessing further previously hidden options, + symbol providing power options.

The square symbol on row 7 provides the following previously hidden options for:
- Row 1 - General - Autoplay, Improved Track Scroller, Volume Limit, Keyboard layout
- Row 2 - Gestures
- Row 3 - Album Art - Reflection, Delay, Multiple Album Art interval, Display Alt art only
- Row 4 - Track Preview - Layout, Show, Single Tap, Autoplay, Prefer over browser
- Row 5 - Plug In Settings

If you ever get stuck using it while learning either tap the sub-menu title to go back or the M button at the device bottom as this will take you back to Home.

As I am sure readers will agree, this gives us a lot of control over the player that was previously unavailable and makes it a far better better music player all round.


Sorting the Music Library and Genres

Next came the music issue. I tried MP3tag and didn't find it sorted all my issues. However I use MediaMonkey extensively so sought to resolve it using that software. MediaMonkey is available for free from www.mediamonkey.com. I find it a great tool and recommend you also do register for the inexpensive paid version of the software.

I sorted all my problems doing the following:

1. Delete the music off the player, it doesn't change tags easily in the Database when the music is on the player.

2. Load it up in Media monkey and add it to the library using menu 'File' then 'Add/Rescan Tracks To Library'. This is important to the next steps. Then make any changes you need to in the library.

3. Now comes the key bit, to update all the music files to reflect what is in the library and get rid of any extraneous information confusing the X7. So using the menu choose 'Tools' then 'Advanced Tag Management' then 'Synchronise Tags'. This will then update the file tags to reflect the library.

If you want to go further using the Advanced Tag Management I mentioned before you can clean the file tags first. This will clear all information from the file tag before putting the latest version back using the Synchronise Tag facility. However and this is pivotal, you must have added the files to the library first or you won't have any information to add to the tag once you have cleaned it. most of us shouldn't need to do the Clean Tag step.

4. Although you can then 'File - copy' in your operating system to the media player, I found a great way to copy the music back was to use Synchronise facility in MediaMonkey.

With your X7 connected, first go to 'Tools', 'Options', 'Portable Audio Devices' then find 'X7 HDD' from the list. Click 'Configure' and then you can choose how the music is copied over. Choose the 'Device Configuration' tab and I found it helped to click 'Synch All Album Art To Track Folders' and especially 'Use Only The First Genre When Multiple Genres Exist'.

I also recommend clicking the 'Configure' button on the 'Sync Tracks To' item at the top or just typing the following into it:
\Music\<Album Artist>\<Album>\<Track#> - <Artist> - <Title>

This will ensure the music goes into folders by the album artist (including Various Artists' then the album, then a file structure of the Track - Artist - Track Title.

You can choose however works for you though, by genre for example as a master folder.

I don't do auto-synching and like to be in control, but you could also set those settings.

5. I then pick the music I want from the library and right click on it, then 'Send To' and then 'X7 (HDD) Synchronise' from the sub-menu that appears. The music will then copy into the X7 as configured in step 4.

6. Once complete you can disconnect the media player safely in the standard method within your operating system and let the database on the X7 rebuild.


Resolving the Windows drive disconnection issue

Finally the third issue was the item disconnecting as a Drive in Windows when copying large amounts of music onto it. Using MediaMonkey Synchronise solved this as it puts only each track into memory rather then Windows or even the excellent TeraCopy. A problem solved simply and easily.


In Summary

Once this is done your X7 should be the music player you hoped it would be. I haven't had a problem since. I went from frustrated in my move from a J3 to a Cowon advocate once again. Huge thanks to the creator of the UCIs, in particular the Sense one (others work too). I also took guidance from posts in this and the AnythingButiPod forums initially to help develop the approach in this guide.


So I hope it is helpful and you enjoy your X7 to its full potential.

If I can help further please do not hesitate to ask.

To help those having problems who have posted into the forum, I have written short linking replies back to this one so they will be emailed to alert them. Apologies for mentioning this post multiple times but hopefully it might then help people receive the help they need.

Many thanks

cheers
Mark

Last edited by Mark Coyle; 06-12-2011 at 09:51..
Mark Coyle is offline View Mark Coyle's Photo Album   Reply With Quote

Advertisement [Remove Advertisement]

Old 06-13-2011, 12:29   #2
Sphinx
Junior Member
 
Join Date: Jun 2011
Posts: 22
Default Sense UI

Hi guys,
I am new here and to Cowon. I have an X7 and tried to install the SENSE interface, it installed but kept on flashing continuously and did not react to anything else. Did I do something wrong or is there a compatibilty issue here?
Kizune: Great job.

Last edited by Sphinx; 06-13-2011 at 12:36..
Sphinx is offline View Sphinx's Photo Album   Reply With Quote
Old 06-13-2011, 12:49   #3
Mark Coyle
Member
 
Join Date: Jun 2010
Posts: 124
Default

Sounds odd. I would delete the Sense files, reboot. Ensure all is okay, then retry.

All I did was download (the new Beta is out today), unzip the files and then copy all the contents of the unzipped folder to the SYSTEM then FLASH UI sub-folder on the Flash drive (should show as a 'X7 FLASH' drive on your network, don't copy to the 'X7 HDD' drive).

Then safely disconnect and reboot. I've done it a second time today to install the new Beta and all was okay.

Let me know how it goes.

cheers
Mark


cheers
Mark
Mark Coyle is offline View Mark Coyle's Photo Album   Reply With Quote
Old 06-13-2011, 12:57   #4
zen-kizu
Formerly "Kizune"
 
zen-kizu's Avatar
 
Join Date: Jan 2009
Location: Germany, Baden-Württemberg
Posts: 5,983
Default

Mark, thanks for recommending my UCIs.
(BTW: Sense is out of beta stage. Just saying.^^)

Sphinx' problem occurs because the g-sensor option is enabled by default. Since the X7 doesn't have a g-sensor, no valid value is returned and the UCI doesn't know which mode (horizontal or vertical mode) to show.
I'm working on an update that replace the g-sensor button in the menu with a tilt button so that X7 users can use the horizontal mode as well. I suppose at the moment you can only use the vertical mode (if Sphinx' problem doesn't happen).
__________________
My setup: Samsung Galaxy Note 3 + Audio Technica ATH-M50 & Shure SE215

Profiles: Google+ // deviantART // flickr
zen-kizu is offline View zen-kizu's Photo Album   Reply With Quote
Old 06-13-2011, 12:58   #5
Sphinx
Junior Member
 
Join Date: Jun 2011
Posts: 22
Default Sense UI

Hi Mark,
Thanks for the quick reply. I did the same, twice, no luck. Everything is still working but I'd love to change Cowon's limited interface.
John
Sphinx is offline View Sphinx's Photo Album   Reply With Quote
Old 06-13-2011, 13:03   #6
Sphinx
Junior Member
 
Join Date: Jun 2011
Posts: 22
Default Sense UI

Hey Kizune,
Thanks for a chance for us non "idiotPod" users to have a great player with a great interface. Am I to understand that you are working on a fix and if not, do you think there is a workaround for this problem?
Regards
John
Sphinx is offline View Sphinx's Photo Album   Reply With Quote
Old 06-13-2011, 13:05   #7
zen-kizu
Formerly "Kizune"
 
zen-kizu's Avatar
 
Join Date: Jan 2009
Location: Germany, Baden-Württemberg
Posts: 5,983
Default

I think the fix will work. I'll release the update in a few minutes so you can try it out yourself.
__________________
My setup: Samsung Galaxy Note 3 + Audio Technica ATH-M50 & Shure SE215

Profiles: Google+ // deviantART // flickr
zen-kizu is offline View zen-kizu's Photo Album   Reply With Quote
Old 06-13-2011, 13:06   #8
doniago
I, Like, Do Stuff Here.
 
doniago's Avatar
 
Join Date: Jun 2005
Location: Burlington, VT
Posts: 4,713
Send a message via ICQ to doniago Send a message via Yahoo to doniago
Default

^^Speaking as an "idiotPod" owner, I'd ask that you dispense with the pointless bashing.

Thank you.
__________________
DonIago
Iron Mod

"When you do things right, people won't be sure you did anything at all."
doniago is offline View doniago's Photo Album   Reply With Quote
Old 06-13-2011, 13:12   #9
Sphinx
Junior Member
 
Join Date: Jun 2011
Posts: 22
Default I...Pod

Hey,
I did not mean to ruffle any feathers here, but point well taken.
Friends?
John
Sphinx is offline View Sphinx's Photo Album   Reply With Quote
Old 06-13-2011, 13:17   #10
zen-kizu
Formerly "Kizune"
 
zen-kizu's Avatar
 
Join Date: Jan 2009
Location: Germany, Baden-Württemberg
Posts: 5,983
Default

I released Sense v1.1.3. Please report back if the new feature works (the tilt button).
http://iaudiophile.net/forums/showpo...&postcount=251
__________________
My setup: Samsung Galaxy Note 3 + Audio Technica ATH-M50 & Shure SE215

Profiles: Google+ // deviantART // flickr
zen-kizu is offline View zen-kizu's Photo Album   Reply With Quote
Old 06-13-2011, 13:39   #11
Sphinx
Junior Member
 
Join Date: Jun 2011
Posts: 22
Default Sense UI

Hi
Sorry Kizune, Still the same, Touch is completely disabled,eventhough lock sign is not shown
John

Last edited by Sphinx; 06-13-2011 at 13:49..
Sphinx is offline View Sphinx's Photo Album   Reply With Quote
Old 06-13-2011, 13:54   #12
zen-kizu
Formerly "Kizune"
 
zen-kizu's Avatar
 
Join Date: Jan 2009
Location: Germany, Baden-Württemberg
Posts: 5,983
Default

Some questions before I release the new update:
- How many brightness levels does the X7 have? (From 0 to ??)
- Does the X7 have a speaker?
__________________
My setup: Samsung Galaxy Note 3 + Audio Technica ATH-M50 & Shure SE215

Profiles: Google+ // deviantART // flickr
zen-kizu is offline View zen-kizu's Photo Album   Reply With Quote
Old 06-13-2011, 13:57   #13
Mark Coyle
Member
 
Join Date: Jun 2010
Posts: 124
Default

Brightness is 1-10, shown as 1 to 9 then Max.

I will try 1.1.3 now and report back.

Thanks Kizune.

cheers
Mark

Last edited by Mark Coyle; 06-13-2011 at 14:02..
Mark Coyle is offline View Mark Coyle's Photo Album   Reply With Quote
Thanks from:
Old 06-13-2011, 14:01   #14
Sphinx
Junior Member
 
Join Date: Jun 2011
Posts: 22
Default Sense UI

Brightness Level: 0-10
In built speaker:Yes
Landscape director: Yes(Pictures)
Firmware version: 2.08
John
Sphinx is offline View Sphinx's Photo Album   Reply With Quote
Thanks from:
Old 06-13-2011, 14:08   #15
Mark Coyle
Member
 
Join Date: Jun 2010
Posts: 124
Default

I can confirm the Horizontal mode works fine for me version 1.1.3.

Many thanks.

cheers
Mark
Mark Coyle is offline View Mark Coyle's Photo Album   Reply With Quote
Thanks from:
Reply

Tags
cowon x7, music player, problem resolution, sense uci, uci

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:40.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Copyright © 2006-2014 CrowdGather |  About iAudiophile |  Advertisers | Investors | Legal | Contact