iAudiophile.net Forums


Go Back   iAudiophile.net Forums > Flash-Memory Players > Cowon D2/D2+ > D2 SD Card Discussion

Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-20-2010, 14:02   #1
whirl
Junior Member
 
whirl's Avatar
 
Join Date: Jul 2010
Posts: 4
Unsure D2+ 16gb FW 2.13 and adata sdhc 16gb class6

I tried to search this section but no one had my problem so I'll just boldly start a new topic.

My PC running debian squeeze detects, mounts, formats (to fat) this card easily via card reader and I can move files back and forth but my D2+ cant even detect it. I cant find the D2_ext when I try to browse for more videos or songs. When I hook the D2+ with the sdhc card in it to my pc via usb it too wont find the sdhc card.

I hope some of my friends have SDHC card somewhere so I can test it but Im afraid its my D2+ that is having problems. So, is there someone out there with similar problems and how did you guys solve it?

Cheers!
whirl is offline View whirl's Photo Album   Reply With Quote

Advertisement [Remove Advertisement]

Old 07-21-2010, 02:54   #2
guilc
Member
 
guilc's Avatar
 
Join Date: Apr 2008
Location: Paris - France
Posts: 31
Default

It may be not well formatted.
First be shure you have CONFIG_SCSI_MULTI_LUN enabled ("cat /sys/module/scsi_mod/parameters/max_luns" should be > 1, may be 512 if enabled). Then what do you see in your syslog when plugging the D2 ?
If it's ok, you should see TWO plugged drives, one for the internal memory, the other for the sdcard.
If not, your D2 has a problem.
If you see both, just recreate the partition table and reformat the sdcard using the D2 as a card reader. This should be OK.
__________________
- D2+ 16GB + 16GB SDHC (rockboxed)
- iAudio 7 16GB
- Sennheiser HD25-1 II
guilc is offline View guilc's Photo Album   Reply With Quote
Thanks from:
Old 07-22-2010, 02:27   #3
whirl
Junior Member
 
whirl's Avatar
 
Join Date: Jul 2010
Posts: 4
Default

Thanks for the quick reply!

Quote:
Originally Posted by guilc View Post
It may be not well formatted.
First be shure you have CONFIG_SCSI_MULTI_LUN enabled ("cat /sys/module/scsi_mod/parameters/max_luns" should be > 1, may be 512 if enabled).
Its 512.

Quote:
Originally Posted by guilc View Post
Then what do you see in your syslog when plugging the D2 ?
If it's ok, you should see TWO plugged drives, one for the internal memory, the other for the sdcard.
If not, your D2 has a problem.
If you see both, just recreate the partition table and reformat the sdcard using the D2 as a card reader. This should be OK.
Looking at the syslog (pastebin1) I cant really be sure if it detects the SDHC card. What do you think?

EDIT starts
I believe it does detect it but the weirdest thing is that it seems to find that same removable drive, which size it cannot figure out, even without the card being in the D2+. Heres the syslog for that (pastebin2). Whether or not the SDHC card is in the D2+ it shows in the "computer" two COWON D2+ named "COWON D2+" and "COWON D2+: COWON". COWON D2+: COWON is the machine it self and that COWON D2+ is just something weird. When I click its properties it says that its location is "computer:///". In the /media/ it rightly shows only the folder "COWON" and nothing else. What do you make of this?

And another weird thing is that tries to open brasero and copy my DVD drives disk when ever I plug in my D2+ with or without the card.

Oh and heres the syslog when the SDHC is opened with card reader (pastebin3)
EDIT ends

EDIT2 starts
And why does it spam "[ 8809.401670] sd 19:0:0:1: [sdc] Assuming drive cache: write through" nonstop to the syslog when sdhc is in the device? "sdc" seems to be the card or the card slot of D2+. Heres a taste from the syslog (pastebin4)
EDIT2 ends

Even more EDIT starts
Here I tried to mount that card while its in D2+
Code:
root@makesomethinguphere:/home/whirli# mount /dev/sdc /mnt/
mount: /dev/sdc: unknown device
root@makesomethinguphere:/home/whirli#
sdc is the cardslot or the card itself but it doesnt recognize it. The disk utility plainly says "no medium detected".
Even more EDIT ends

Which FAT should I use to format the card then? Using the program Disk Utility Ive tried "W95 FAT32 (0x0b)" and "W95 FAT32 (LBA) (0x0c)". Those are the only FAT32 possibilities there. I think that the cowon D2+ uses FAT32 too.

Quite something :F
Cheers!

Last edited by whirl; 07-22-2010 at 03:54..
whirl is offline View whirl's Photo Album   Reply With Quote
Old 07-25-2010, 03:23   #4
guilc
Member
 
guilc's Avatar
 
Join Date: Apr 2008
Location: Paris - France
Posts: 31
Default

So the SD drive seems to be correctly detected

What is the output of "fdisk -l /dev/sdc" (with sd card plugged of course) ?

If it's ok here, you should be able to create a partition :
- fdisk -c -u /dev/sdc
- delete all partitions if any (d then partition number)
- n
- p
- 1
- enter
- enter
- t
- c
- w

Then format the new sdc1 :
mkfs.vfat -s 32 -n D2Ext /dev/sdc1

Then unplug and replug (just to be shure), this should be OK
__________________
- D2+ 16GB + 16GB SDHC (rockboxed)
- iAudio 7 16GB
- Sennheiser HD25-1 II

Last edited by guilc; 07-25-2010 at 03:26..
guilc is offline View guilc's Photo Album   Reply With Quote
Thanks from:
Old 07-27-2010, 21:26   #5
whirl
Junior Member
 
whirl's Avatar
 
Join Date: Jul 2010
Posts: 4
Default

Cool, Ill try that when Im home.
whirl is offline View whirl's Photo Album   Reply With Quote
Old 08-25-2010, 08:31   #6
whirl
Junior Member
 
whirl's Avatar
 
Join Date: Jul 2010
Posts: 4
Default

Quote:
Originally Posted by guilc View Post
So the SD drive seems to be correctly detected

What is the output of "fdisk -l /dev/sdc" (with sd card plugged of course) ?

If it's ok here, you should be able to create a partition :
- fdisk -c -u /dev/sdc
- delete all partitions if any (d then partition number)
- n
- p
- 1
- enter
- enter[/CODE]
- t
- c
- w

Then format the new sdc1 :
mkfs.vfat -s 32 -n D2Ext /dev/sdc1

Then unplug and replug (just to be shure), this should be OK
First of all, Im really sorry that I forgot to reply. Secondly, It wasnt ok, it cant see it.

First the D2+:
Code:
mil@piskui:~$ sudo fdisk -l /dev/sdb

Disk /dev/sdb: 16.5 GB, 16533946368 bytes
64 heads, 32 sectors/track, 15768 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000dccc1

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1       15768    16146416    c  W95 FAT32 (LBA)
Then the card (twice):
Code:
mil@piskui:~$ sudo fdisk -l /dev/sdc
mil@piskui:~$ sudo fdisk -l /dev/sdc
mil@piskui:~$
I do hope youll get this. I tried again formatting the card with card reader and put something in it, again, but no luck. I cant understand why it wont see it, probably its just broken. Which reminds me, need to see my friend about that.

Cheers!
whirl is offline View whirl's Photo Album   Reply With Quote
Old 08-26-2010, 02:35   #7
guilc
Member
 
guilc's Avatar
 
Join Date: Apr 2008
Location: Paris - France
Posts: 31
Default

Argh, so the device is seen by the kernel, but no disk geometry and no partition table are available :'(
This looks very bad.
Perhaps I miss something, but for me, it looks like a problem with the D2 card reader.

Just to be shure (it hurts to say that ) : have you tried to plug the D2 under windows ? Same thing ? it does not show the sd card ?
If I'm not wrong, it will not work too, but...
__________________
- D2+ 16GB + 16GB SDHC (rockboxed)
- iAudio 7 16GB
- Sennheiser HD25-1 II
guilc is offline View guilc's Photo Album   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:22.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Copyright © 2006-2014 CrowdGather |  About iAudiophile |  Advertisers | Investors | Legal | Contact